[Samba] [CSI] smb.conf share definition "force group =" option

Mlist mlist at linux-house.net
Wed Dec 3 17:26:38 GMT 2003

Dear John, i am wondering whether u have solved this....i had problems earlier 
with options such as;

1. only user
2. force create mode
3.force directory mode

the options  didn't seem to work ( on samba v 2.2.7a).

I solved the problem for our club by just working on chmod 0777 and using 
option "valid user , write list " to make files/folders writable for certain 
individuals who are working on similar things...


>On Tuesday 02 December 2003 19:37, J. Nyhuis wrote:
> Greetings,
> 	I am using samba-3.0.1pre3-1, and have noticed that the "force
> group" and "force user" option no longer seems to work.  In spite of the
> option being set, the files copied are set to the current users
> user and primary group.  Am I missing something with regards to how this
> is supposed to work or is this a bug?
> 	This is one of my share definitions for a team of people where
> this option does not work.  If I copy a file in as a user that is a
> member of the cellbio group (e.g. testuser), the unix permissions of the
> file are set to testuser:testuser, not testuser:cellbio as I would expect,
> denying access to the file for everyone else in the cellbio group.
> [cellbio]
>         comment = Filespace for the Cell Biology Team
>         path = /share/teams/CellBio/
>         browseable = yes
>         valid users = +&cellbio
>         read only = yes
>         force group = cellbio
>         write list = @cellbio # read only, except for people in the
> "cellbio" group
> 	If folks could point out anything I am missing I would appreciate
> the advice.  Thanks on advance.
> John N.
> cabal at u.washington.edu

More information about the samba mailing list