[Samba] Problem connecting to Samba server over PPP connection

Adam Reid areid_van at hotmail.com
Thu Apr 17 05:33:49 GMT 2003


I'm trying to connect to my samba server over a PPP connection (which is
actually a PPTP VPN connection). I've got the PPP link configured and the
routing setup so I can ping back and forth between the server and client,
and I can also make tcp connections over the link. The server which samba is
running on has a LAN connection in addition to the PPP connection, and I can
connect to the samba server on the LAN without any problems. The problem
arises when I try to connect to the samba server over the PPP connection. If
I try to connect to port 139 from the windows client, I get a connect failed
error. It seems that Samba isn't listening for connections from the PPP

I've tried to solve the problem by using the following options in the

interfaces = eth* ppp* lo
bind interfaces only = no

but this doesn't help. Samba still doesn't seem to be listening on the PPP
interface. I know that the packets are making it to the server, since
tcpdump gives the following output when I connect ( is the
client side of the PPP link and is the server side):

>tcpdump -i ppp0 -nn
20:56:06.925870 > S
188147292:188147292(0) win 16384 <mss 1460,nop,nop,sackOK> (DF)
20:56:06.925888 > icmp: tcp port 139
unreachable [tos 0xc0]

Can anybody tell me what I've got to do to get Samba to listen on the PPP
interface? Any help is greatly apperciated!

More information about the samba mailing list