[Samba] NetBIOS name of 15-characters still doesn't work

Gerald Carter jerry at samba.org
Mon May 6 12:15:03 GMT 2002

On Fri, 3 May 2002, MCCALL,DON (HP-USA,ex1) wrote:

> Hi Ken,
> Same issue exists for released Samba 2.2.4 version on HP-UX 11.11, trying to
> join a WIN2k domain:  created two machine accounts on the win2k domain:
> ecl20001234567  works
> ecl200012345678 fails

Are you trying to create the machine account before?
If so, then this might be the bug as NT passwords are limited 
to 14 characters right?  The default password assigned to
a m,achine trust account in Server Manager (or mmc) is the machine's
netbios name in lower case letters.  Does this work in an NT
domain with an NT client?

btw...I just tried this when building the latest RedHat RPMS
on samba.org and "smbpasswd -j DOMAIN -r '*' -UAdministrator%pass"
worked just fine.

cheers, jerry
 Hewlett-Packard                                     http://www.hp.com
 SAMBA Team                                       http://www.samba.org
 --                                            http://www.plainjoe.org
 "Sam's Teach Yourself Samba in 24 Hours" 2ed.      ISBN 0-672-32269-2
 --"I never saved anything for the swim back." Ethan Hawk in Gattaca--

More information about the samba mailing list