[Samba] NetBIOS name of 15-characters still doesn't work

MCCALL,DON (HP-USA,ex1) don_mccall at hp.com
Fri May 3 11:49:02 GMT 2002

Hi Ken,
Same issue exists for released Samba 2.2.4 version on HP-UX 11.11, trying to

join a WIN2k domain:  created two machine accounts on the win2k domain:
ecl20001234567  works
ecl200012345678 fails


-----Original Message-----
From: Ken Cross [mailto:kcross at nssolutions.com]
Sent: Friday, May 03, 2002 2:32 PM
To: samba at lists.samba.org
Subject: [Samba] NetBIOS name of 15-characters still doesn't work


We have confirmed that 15-character NetBIOS names cannot join a domain
in any of the following platforms:

  Samba 2.2.3a on Solaris
  Samba 2.2.2  on NetBSD
  Samba 2.2.3a on NetBSD
  Samba 2.2.4-pre on NetBSD (May 1 version)
  Samba 3.0    on NetBSD (May 1 version)
  Samba 2.2.3a on Linux 7.2

We've tried with multiple PDCs (NT4 and Win2K).  Windows clients can
join just fine.  14-character names work OK.  I've traced the packets
and they're identical, except that the PDC returns "ACCESS_DENIED" with
the 15-character names.  We've done it with a minimal smb.conf:

 netbios name = A23456789012345
 workgroup = NT4DOMAIN
 security = domain

Has anyone seen anything similar?  Any ideas?


To unsubscribe from this list go to the following URL and read the
instructions:  http://lists.samba.org/mailman/listinfo/samba

More information about the samba mailing list