[Samba] Samba + NFS virtual directories question

Chris Knadle cknadle at aeroflex.com
Wed May 1 11:04:02 GMT 2002

Hey, Joseph.

> I don't know what OS you are using, I prefer to use home directories but
> I tried one set at /opt/applix (automounted to the opt) drive and
> mounted unde winnt as \\mfg\win_c. Worked perfectly fine with the size.

   Win 95, 98, ME, 2000, XP.  All behave the same way on this.
   Check your /opt directory on your system.  My guess is that it should look 
something like the following:

drwxr-xr-x	2  root	wheel	0 May  1 10:10  opt

   This means that the virtual directory where you're mounting your nfs 
shares does not have any space available.  When you try to share this 
directory with samba, everything under it will show 0 space free.
   Try this: make a new share on your system, which looks like this:

	path = /opt
	read only = Yes
	guest ok = Yes
	browseable = Yes

   After mounting a _directory_ under [win_test] on a client, and looking at 
the properties, you'll probably see that the share has 0 space.  ;-)

   What you've got below works _because_ the actual share is _not_ of the 
/opt directory directly.

> [win_c]
>         path = /opt/applix
>         read only = Yes
>         guest ok = Yes
>         browsabel = yes
> auto.opt
> applix          mfg:/export/home/opt/&
> local           mfg:/export/home/opt/&
> netscape        mfg:/export/home/opt/&
> netscape-6      mfg:/export/home/opt/&
> oracle          mfg:/export/home/opt/&
> staroffice      mfg:/export/home/opt/staroffice/5.2
> auto.master
> /home   /etc/auto.home
> /misc   /etc/auto.misc  --timeout=60
> /opt    /etc/auto.opt   --timeout=60

More information about the samba mailing list