[Samba] long username - netlogon problem - access denied

robert at zilcoski.com robert at zilcoski.com
Fri Jul 19 12:24:02 GMT 2002

I'm running samba 2.2.4 on rh 7.2.  Everything's been working well 
for months.

I use the domain logon feature to map drives when '98 users logon 
to the domain.

Recently I've had a couple machines refuse to process the logon 
script and I can't figure out why.

Here's the Windows output:

C:\WINDOWS> Access denied  - Z:\ALEXA~03.BAT

C:\WINDOWS> Access denied  - Z:\ALEXA~03.BAT

C:\WINDOWS> Access denied  - Z:\ALEXA~03.BAT

C:\WINDOWS> Access denied  - Z:\ALEXA~03.BAT

I've tried putting PAUSE as the first command in the batch file.  It 
never gets there...

I've made sure file permissions are not an issue.  The logon script 
file is owned by that user (and the group 'dos').

The directory data55 has been chowned by 'dos' with -R 
The directory has been chmod'ed with -R 2770

A friend suggested using shorter (under 9 letter) user names as a 
test, and this is a good workaround.

I have finally narrowed it down (I think) to the fact that these 
affected machines have problems logging in with usernames longer 
than 8 characters, (although they didn't used to).  
I have two usernames that are long that both cause troubles on the 
'bad' '98s: administrator and alexandra.  Both usernames can log in 
fine from several other Win'98 machines on the network.  Plugging 
a 'good' Win'98 machine into the same cat 5 cable as a broken one 
does not break it.

Creating user names of admin and az was the workaround.  I'm just 
wondering why the long usernames suddenly stopped working -- on 
some machines and not others!!!

Here's some (hopefully) relevent smb.conf entries:

Some of the commented stuff is stuff I've tried to use the resolve 
the problem, no joy!

This is the only domain controller on the network.  Everything else 
is Win '98's (about 10 boxes) and a Win-ME.

netbios name=r100
encrypt passwords=yes
wins support=yes
domain master=yes
domain logons=yes
time server=yes
server string=r100
logon script=%U.bat
#hosts allow=, 192.168.1. EXCEPT,,
#name resolve order = hosts
read size = 8192
#dos filetimes = yes
#fake directory create times = yes
#dos filetime resolution = yes
#delete readonly = yes

case sensitive=no
#follow symlinks=yes
read only=yes
guest ok=no
write list=administrator
browseable = no

I was wondering if anyone else has had this problem, and why it 
only affects a couple of machines (out of many), while the other 
Windows '98 machines process the login script just fine for the 
long usernames.  It's been very irritating.

Thanks in advance for any insights anyone can provide.

I've searched everywhere and haven't found a solution.

P.S. I believe this isn't a password issue, since entering a bad 
password will not get you far enough for the login script console 
window to open on the '98 box.  (Where the access denied 
messages start scrolling)

PPS, If I re-do (reload the entire OS) on the Win'98 box, the 
problem is fixed.  I just hate to have a problem where the only 
solution is to redo the '98 box.


More information about the samba mailing list