[Samba] my printers are still paused in Win2k and WinNT 4.0

Shane Drinkwater Shane_Drinkwater at pa-ucl.com
Wed Jul 17 15:34:02 GMT 2002

Again no dice. This is a very strange problem!?! I am now debating to
compile LPRng with done_jobs=0 to see if that works( at this point I doubt
it). I also have some more interesting data for the problem
	1.)The HP 4m printer all of a sudden started to work it showed
"ready"!! I come back about 5 mins later and it showed "pause" again????
This means other print jobs on the printer are affecting the samba print
	2.) I have switched everything over to tcp 9100 and back again to
lpd after testing the done_jobs parm still no fix.....
	3.)  I have never printed a job on this server it is a test. I
figured that print_jobs=0 means that lprng keept old jobs around to so I
cleared out all of the queues and reset up the printers. again paused
printer,, With no print jobs ????
	4.) Is CUPS better for communicating status info with samba? I would
hate to switch to CUPS since CUPS looks more complicated.
	5.) is there a way to get samba to kick out more detailed info about
the printer status( or what it thinks is the printer status).
	6.) I am checking the status by double clicking on the computer.
then the printers share on that computer. I then click on a printer and wait
for the refresh on my win2k to say ready or fail....
Any Ideas are helpful!!!

P.S. The Damm printer show ready again as I write you this message. I will
check it in the morning.. 

-----Original Message-----
From: Van Sickler, Jim [mailto:vansickj-eodc at Kaman.com]
Sent: Wednesday, July 17, 2002 2:17 PM
To: 'Shane Drinkwater'
Cc: Samba-L (E-mail)
Subject: RE: [Samba] my printers are still paused in Win2k and WinNT 4.0

> -----Original Message-----
> From: Shane Drinkwater [mailto:Shane_Drinkwater at pa-ucl.com]
> Sent: Wednesday, July 17, 2002 10:02 AM
> To: samba at lists.samba.org
> Subject: [Samba] my printers are still paused in Win2k and WinNT 4.0
> Jim,
> I have placed the done_jobs in my lpd.conf and it didn't fix 
> the problem.

try done_jobs=0

(maybe the space between = 0 is causing it to be ignored?)

> How can the done jobs parm effect the samba system if the 
> queues don't list out any jobs to print???

If you look in your lpd spool dir, you'll see the last
job is still there;  LPRng knows it's purpose, but
samba doesn't...lpq will tell you that there are
no printable jobs, but samba sees it as Paused...

  I'm running OpenBSD, and putting it in lpd.conf didn't
fix it for me, either.  Putting :done_jobs=0 in the
.common section worked for me.

Here's a snippet of my /usr/local/etc/printcap:
.common:cm=Common Settings:done_jobs=0:sd=/var/spool/lpd/%P:mx=0:sh:lf=log \

hp4plus:cm=HP4Plus by Graphics PC:tc=.common:rm=


Maybe this will help.


More information about the samba mailing list