[Samba] Samba Team? - "ld.so.1: ls: fatal: relocation error: file /usr/lib/nss_winbind.so.1: symbol socket: referenced symbol not foun d"

Thomas, Daniel J. Daniel.Thomas at jhuapl.edu
Mon Feb 18 06:02:06 GMT 2002

I've actually already done the tests you suggested.  Everything Checks out.
Here is the output from the getent passwd (the JHUAPL domain has 1000+
users, so I asked for my entry only):
# getent passwd JHUAPL+thomadj1
JHUAPL+thomadj1:x,omadj1:10000:10000:Daniel James
Sun doesn't seem to have ldconfig, but I have rebooted since I installed the
library and links and that is supposed to yield the same effect.  "Secret is
good."  "wbinfo -u" works (my sun machine is a member of the JWAD domain,
but my user accounts are in the trusted JHUAPL domain).  I did notice that
some of the JHUAPL users are in all Capital letters, while others are
lowercase.  Could this have something to do with it?  Winbind show my
username in caps when I do the winbind -u, but shows it as JHUAPL+thomadj1
in the passwd database.  
Everything seems to be functioning on the Samba end.  What should the
Owner/Group/World permissions on Unix side of the shared Samba directory be?
I was under the impression that it should be owned and writable by root and
all samba would handle the share permissions, but when I use the default
UNIX rights on the directory, the Samba users couldn't write to it.  When I
made it Owner/Group/World writable, then it worked fine.  
Also, if I write a file on the NT side to the Samba directory and get a file
properties window, I can see the owner of the file as JHUAPL\USERNAME rather
then UNIXMACHINE\USERNAME (which is what I really wanted to use winbind
for).  If I write a file on the UNIX side and look at it from the NT side it
shows UNIXMACHINE\USERNAME correctly.  If the Samba share has only Unix
files in it and I do an ls -l on the UNIX Side, then the error doesn't
occur.  If I write a file or a directory from an NT machine to the Samba
share, then the ls -l has this error.

-----Original Message-----
From: Esh, Andrew [mailto:AEsh at tricord.com]
Sent: Friday, February 15, 2002 4:15 PM
To: 'Thomas, Daniel J.'; 'Herb Lewis'
Cc: Samba (E-mail); 'samba-technical at lists.samba.org'
Subject: RE: [Samba] Samba Team? - "ld.so.1: ls: fatal: relocation error:
file /usr/lib/nss_winbind.so.1: symbol socket: referenced symbol not fou n

You can test if winbind is able to resolve user IDs internally with "wbinfo
-u". This uses the samba tool "wbinfo" to connect directly to the running
winbind daemon and list all the Windows domain users. If that fails, then
you have problems with the winbind daemon itself. The authentication between
winbind and the PDC can be tested with "wbinfo -t", which is usually the
next thing which should be checked in this situation.

If wbinfo succeeds, then you can test the NSS connection to the winbind
daemon with "getent passwd". This lists all the Unix users, as well as the
Windows users being translated by winbind. The Windows users can be
identified by the prepending of the domain name in front of their user name.
If that fails, then there is a problem with libnss_winbindd.so,
/etc/nsswitch.conf, or symlinks from the lib directory to wherever the
library is stored. Also remember to run ldconfig (does Solaris have an
equivalent?) to get the library into the cache. Test this with "ldconfig -p
| grep winbind".

It sounds as though you have NSS configured right. I can't tell if the nss
library is installed right. I can't tell if winbind is running right, or if
it authenticated wit the PDC. The above tests will answer those questions.

Hope this helps. 

-----Original Message----- 
From: Thomas, Daniel J. [ mailto:Daniel.Thomas at jhuapl.edu
<mailto:Daniel.Thomas at jhuapl.edu> ] 
Sent: Friday, February 15, 2002 2:46 PM 
To: 'Herb Lewis'; Thomas, Daniel J. 
Cc: Samba (E-mail); 'samba-technical at lists.samba.org' 
Subject: RE: [Samba] Samba Team? - "ld.so.1: ls: fatal: relocation 
error: file /usr/lib/nss_winbind.so.1: symbol socket: referenced symbol 
not foun d" 

I've recompiled samba 2.2.3a and still any time I do a ls -l in a directory 
where there are files from a PC I get the error : 

ld.so.1: ls: fatal: relocation error: file /usr/lib/nss_winbind.so.1: symbol

socket: referenced symbol not found 

If I shut off winbind or take winbind out for my /etc/nsswitch.conf file, I 
can get a directory listing and it lists the users ID that winbind assigned 
to the user that created the file. 

When I compiled samba using the April 2001 GNU C compiler (from the April 
2001 Solaris distribution CD set), everything compiled correctly except a 
warning from a file called "clistr.c".  Is this something to do with the way

ls integrates with winbind, or does this file even matter?  

A regular ls on the directory has no problems.  I get the same error though 
when I try and change the group ownership using chgrp.  Everything else 
seems to be functioning just fine, although I had to change the Unix 
directory I was sharing to owner/group/world writeable.  I thought the 
directories samba wanted to share were supposed to be owned by root? 

I assume that what is happening is when I do an ls -l, UNIX tries to query 
the various password lists in the order listed in nsswitch.conf.  Since 
there is no listing with winbind off, the system just displays the user ID 
as if the user who created the file had been deleted.  I think UNIX is 
having trouble reading the user/group information from winbind. 


-----Original Message----- 
From: Herb Lewis [ mailto:herb at sgi.com <mailto:herb at sgi.com> ] 
Sent: Friday, February 15, 2002 1:06 PM 
To: Thomas, Daniel J. 
Cc: Samba (E-mail) 
Subject: Re: [Samba] "ld.so.1: ls: fatal: relocation error: file 
/usr/lib/nss_winbind.so.1: symbol socket: referenced symbol not found" - 
Samba Team? 

"Thomas, Daniel J." wrote: 
This works fine for me but I don't run solaris. It looks like your 
nss_winbind.so did not build correctly and is missing a function 

> Hey, 
> I'm getting this error when ever I've written a file from my Win2k Pro 
> machine to my samba share.  Using Samba 2.2.3.  Built on Solaris 8.  Using

> winbindd.  I created the sym links as suggested under /lib (really 
> /usr/lib):  nss_winbind.so.1 -> libnss_winbind.so    nss_winbind.so.2 -> 
> libnss_winbind.so 
> Are there some other sim links I need somewhere or is this error something

> from the code? 
> Again, the error is like this: 
> adams{root}5: ls -l 
> total 2 
> ld.so.1: ls: fatal: relocation error: file /usr/lib/nss_winbind.so.1: 
> socket: referenced symbol not found 
> Killed 
> -Dan 

Herb Lewis                               Silicon Graphics 
Networking Engineer                      1600 Amphitheatre Pkwy MS-510 
Strategic Software Organization          Mountain View, CA  94043-1351 
herb at sgi.com                             Tel: 650-933-2177 
http://www.sgi.com <http://www.sgi.com>                        Fax:

-------------- next part --------------
HTML attachment scrubbed and removed

More information about the samba mailing list