[Samba] (no subject)

Chris chrisd at better-investing.org
Mon Feb 4 16:21:34 GMT 2002

To: samba at lists.samba.org Subject: Printers suddenly unavailable

Hello everyone.

I have a strange problem. I am administering a small network. I have a 
samba server on an RH 7.1 machine (samba 2.2.2 compiled from source). The 
client is an XP machine. It was working fine for months, and suddenly -- 
for no apparent reason I cannot connect to the printers served by the Samba 
machine. They are there, they are browseable (when I make them so), I can 
even reinstall them -- but everytime I try to print to them I get "access 
denied". I also happen to have netatalk working on this system, and I can 
print to all printers with the macintoshes -- so I know there is nothing 
physically wrong.
The RH 7.1 machine running samba is also a dual-boot to windows 98, when I 
do this and share the very same printers, it works as well. What is really 
strange is that when I log into the XP machine as root, I can print! No one 
else can, only root.

Now, my user is a member of the adm, root, and wheel groups. On the XP 
machine my user is a member of the Administrators group (as is root). I 
have tried using "admin users =" and "valid users =" on the printers in 
smb.conf and it didn't change a thing. I have checked the perms on the 
spooling directories and they are fine, and all owned by lpd. I have 
stopped and started lpd and smbd, rebooted --nothing. I have checked my 
printcap files, and nothing has changed! (and I can print all day long from 
the rh7.1 machine to any printer).

I created several new users with and without these groups, and nothing 
worked. Only root prints.
I was printing fine earlier in the day, and suddenly, it just stopped. I 
wasn't doing any work on the machine (I was ssh'd into another machine in 
terminal window but that was it). On the XP machine I installed cygwin 
between when I was able to print and suddenly not print.
At first I thought maybe XP did an auto-update that caused it, but since 
root can print that doesn't seem likely.
Anyone have any Idea what is going on here?

Thanks for your help.


My smb.conf that *was* working so well:

netbios name = SamServer
workgroup = "HOMIES"
os level = 64
preferred master = yes
domain admin group = @adm
domain master = yes
local master = yes
create mask = 0700
directory mask = 0700
security = user
add user script = /usr/sbin/useradd -d /dev/null -g 100 -s /bin/false -M %u
encrypt passwords = yes
domain logons = yes
logon path = \\%N\profiles\%U
logon drive = H:
logon home = \\SamServer\%U
logon script = logon.cmd
browseable = no
path = /usr/local/samba/ntprofile
writeable = yes
create mask = 0600
directory mask = 0700
# My network stuff
browseable = yes
path = /var/spool/lpd
guest ok = Yes
printable = Yes
printer name = laserjet4
valid users = me,root,her

browseable = yes
path = /var/spool/lpd
guest ok = Yes
printable = Yes
printer name = macwriter
path = /home/homie_tmp
valid users = me,root,her
read only = No
path = %H/sam
read only = No
browseable = No
browseable = no
path = /usr/local/samba/netlogon
writable = no
guest ok = no
write list = root
path = /home/common
read only = no
valid users = me,her,root
force user = her

More information about the samba mailing list