[Samba] Function address causes a protection fault.

Gerald (Jerry) Carter jerry at samba.org
Wed Aug 14 06:18:52 GMT 2002

On Mon, 12 Aug 2002, Trevor Fraser wrote:

> Hello all.
> I'm using a HP Office Jet K80 on a RedHat 7.3, kernel 2.4.18-3, using
> the USB port and Samba 2.2.3a.  I've installed the new driver to support
> usb printing, namely HPOJ-0.80.  I can use lpr <filenames with.ps> and
> it prints fine, also a test page from printconf-tui is no problem.  So
> the Linux side seems to be fine.  When I try set up the printer on the
> windows machine, I get the following error when I click on properties,
> or most other options:
> Function address 0x75410a3 causes a protection fault. (exeption code
> 0x0000005)  Some or all property page(s) may not be displayed.
> I tried from another Win2K p.c., but the same error with the exception
> of function address being 0x3c110a3.  What would be producing such a
> fault?  Is it a share problem, printer problem, or some thing on the
> windows machine/domain logon?

Upgrade to 2.2.5 and apply the source patches in 

2.2.3a was not so great wrt to driver downloads...

cheers, jerry
 Hewlett-Packard                                     http://www.hp.com
 SAMBA Team                                       http://www.samba.org
 --                                            http://www.plainjoe.org
 "Sam's Teach Yourself Samba in 24 Hours" 2ed.      ISBN 0-672-32269-2
 --"I never saved anything for the swim back." Ethan Hawk in Gattaca--

More information about the samba mailing list