Could not connect to a Win3.1 share

Indrek Zolk zolki at
Wed Oct 3 13:57:03 GMT 2001

Thank you, but did not work. I tried to share an empty directory and a
directory with 3 files (no accented characters or other tricks in
filenames), in either cases I got this For_next blabla.
By the way, get source dest works!, but then I sould know what files I
have to get. And Amanda (backup software), to my mind, needs to get the
listing, otherwise backup fails.
More fname also works. Win3.1 machine has a full access share, under
password. By the way, password had to be entered into smbclient in capital
letters, not depending in what case the password actually was.


Just some ideas:
Maybe you have some oddly named file on your windows box which is
smb and ls. I had a problem yesterday with a file name -T on my linux box.
grep keep giving me an invalid option -T message when I tried grep Pattern
in that directory.
On the get error, just some thoughts:
You might try specifying both the local and remote name in the get
and perhaps try them in different order (get remote local and also try get
local remote) and see if that offers any clues.
It sounds like you can't write to your local directory, would be my guess.
How are your permissions?
At the smb prompt, Try more remotefile and see if you can list the file.

> A problem: Samba (2.0) can log in to a Win31 share (I get a prompt), but
> after that I obtain
> smb: \> ls
> Error: Looping in FIND_NEXT??
> ERRSRV - ERRerror (Non-specific error code.) listing \*
>                 51250 blocks of size 8192. 26860 blocks available
> If I try to get some file that exists, I obtain
> smb: \> get Anu.doc
> Error opening local file Anu.doc
> What could be the solution?
>                               Indrek Zolk,
>                                       Tartu Univ., Estonia
> -- 
> To unsubscribe from this list go to the following URL and read the
> instructions:

More information about the samba mailing list