Win98SE to Samba 2.0.10 Problems

Foss.KS at Foss.KS at
Fri Nov 30 04:59:03 GMT 2001

Thanks for the answers so far but I haven't been able to come up with an
solution yet :(

Some new info (see bottom of email for history):
1.	I upgraded to 2.0.10 on my Mandrake 8.0, no change to the transfer
2.	I attempted to ftp a file from the Win 98SE PC to my Samba Server,
didn't work.  So I can assume that it is not specifically Samba problem.
3.	I have changed the NIC cards in both the Win98SE machine and the
Linux server, no change.
4.	Now here's the funny one...I made a quick install of ZipSlack 7.1 on
my work laptop to help narrow down the problems.  I sent up Samba 2.0.3 and
voila...I have no transfer problems to speak of to the Slackware Samba
machine.  So this makes me think that it may be a problem on the Mandrake
8.0 machine...don't know for sure.
5.	I then set up Redhat 7.1 on a separate partition on my server.  Set
it up to run and boom, doesn't transfer.  So now my server has had both
Mandrake8.0 and Redhat7.1 and both have the same problem.
6.	As a last resort, I am looking for a distro to put on top of my
Win98SE that can check once and for all if the problem is in my Win98SE. (I
just need a distro that can work with my Netgear FA311 NIC.) If I can FTP
something from the machine running Linux...then it's Win98.  If I
can't...well it's either the wiring (which I've checked) or the Linux

Any ideas?

Kevin Foss
Ottawa, Canada

Hi Don

First, I'm glad you're using samba on mdk ;o)
I would also suspect something wrong in the configuration of you win98SE
Have you tried to transfer files through ftp from windows to linux, just for

checking it works properly?

Also, I strongly suggest you to update your samba 2.0.7 from the mandrake 
mirrors with 2.0.10, as there is a security issue on that specific version.

The update can be found here:
(or any other mirror listed here:)

The security advisory concerning samba on 8.0 can be found here:

Also, there is an unsupported 2.2.X version for 8.0 here:
or here:

but remember it's not officially supported on 8.0.

Sylvestre Taburet

Le Mercredi 28 Novembre 2001 17:02, MCCALL,DON (HP-USA,ex1) a écrit :
> Well, that's wierd...
> Question; you have 2 win98se boxes that do NOT have this problem, and
> 1 that does.  If you put in the exact same card from a win98se box
> that WORKS into the one that doesn't, does it still fail?  And if it
> does, take a look at the driver for the card in the win98se box that
> fails compared to the one that works - is the driver the same revision?
> are the parameters for the driver the same?  If not, try copying the
> driver from the working pc over to the bad pc, and updating the driver
> in the device manager....
> I'm no pc expert, but it does sound more like a driver/hw issue on the
> win98se pc than anything in Mandrake...
> If the above (at the card and driver level) don't take care of it,
> check the tcpip settings between the two machines in the registry,
> this is a long shot...
> Don
> -----Original Message-----
> From: Foss.KS at [mailto:Foss.KS at]
> Sent: Wednesday, November 28, 2001 10:45 AM
> To: samba at
> Subject: Samba 2.0.7 and Win98SE
> 	I have been having an irritating problem with my home network.  My
> network consists of 1 PC running Mandrake 8.0 as the file server with
> 2.0.7, three PCs running Win98SE and one PC running Win XP.
> 	I have had the network running for almost two years in various OS
> configurations and for the most part have had smooth operations.  However,
> my problem comes when I try and copy, move, or save any files over 15KB to
> the Samba shares from one specific Win98SE PC.  I can perform actions on
> the Samba shares and move them to the Win98SE PC but not the other way
> around. What makes this so confusing is that I can have no problems moving
> files on or off this machine from any other PC including the server.  I
> mount the Windows share with Samba and pull them from Win98SE PC.  As
> this Win98SE PC has absolutely no problems transferring files from any PC
> except the Linux machine.  The Samba log file for this machine states that
> there was a "read socket error" in the util_sock.c" file and that the
> "connection was reset by peer".
> 	Now to add another twist, I have put three different PCI ethernet
> adapters into the Win98SE PC and all have the same issue.  But, I tried a
> USB Ethernet adapter on this machine and it works perfectly (although very
> slow).  I have moved the network adapter around into different PCI slots
> and each card had difference chipsets.  I have physically checked the Cat
> cable and connection and there are no issues with the line quality.
> 	Could my problem be associated with a transmit buffer setting on my
> Win98SE machine or a read buffer setting in Samba?  The message in the log
> file would drive me to believe that it is a problem on the Win98SE
> However, it could be anything and I can't figure out which machine the
> problem resides on.  My only guess is that there is an issue with the size
> of the transfer and that when I use the USB Ethernet adapter, the transfer
> is slow enough not to overrun any buffers.
> 	Any help would be appreciated. 	I will attempt to get my smb.conf
> file if needed.
> Kevin Foss
> Ottawa, Canada

Sylvestre Taburet - Project Manager
Mandrakesoft S.A. - 43, rue d'Aboukir, 75002 Paris - FRANCE
+33 (1) 40 41 00 41 -

More information about the samba mailing list