RE smbmounts hang around after windows client disconnects

Noel Kelly nkelly at
Fri Nov 30 04:32:02 GMT 2001


Just so you know you are not alone - I had exact same problem the other day.
I was confused because it had successfully copied the 1Gb of files and then
hung during disconnection.  Windows source was a 2000 server.

I realised afterwards that I had not compiled 2.2.2 --with-smbmount and was
using the RH installed version (Version 2.0.6) but have yet tried it again.


Date: Thu, 29 Nov 2001 23:22:45 -0500
From: Joel Hammer <Joel at>
To: samba at
Subject: smbmounts hang around after windows client disconnects

Using 2.2.1a and a 2.4 kernel patched for win4lin. 
Everything is working but:
I mount all the available network shares on my linux box as root to one
network directory.
If a windows client shuts down while the linux box is still connected, the
share is not removed from my mount list or from /proc/mounts
It cannot be removed with umount. I can kill the smbmount with kill -15 but
the share is still there with mount.
Telinit to 1 does not remove the share.
Attempts to access the share after the windows client shuts down results in
the process hanging. 
When running KDE, the icons all disappear after I shunt down the offending
window where I tried to access the share.
I cannot reboot successfully after this, with none of the other drives being
umounted successfully, unless I do it by hand before I reboot.
The rebooting process just hangs during shutdown. None of the other mounts
are umounted during this reboot, and all have to be fsck'ed during the
next reboot. This takes about 40 minutes.
In short, this is a real nuisance.
Any insight appreciated.

Noel Kelly
Tarsus PLC
Commonwealth House
Chalk Hill Road
W6 8DW
United Kingdom

Direct Line	: (44) 020 8846 2701
Switchboard 	: (44) 020 8846 2700
Fax		: (44) 020 8846 2801

More information about the samba mailing list