granting access to other linux directories

Ian Lipsky merk at
Mon Sep 18 20:39:51 GMT 2000

I have a linux server already up and running. I'm trying to access it 
through a win2k box.

I can access my linux home directory, as well as a public directory i 
created initially. However, i'm trying to play with the permissions to make 
sure i have everything set correctly and dont have more permissions then i 
need. So I created another directory called test.

I did chown smbuser.smb test , and i also did chmod 2777 test.

But when i open my network neighborhood, i dont see it. And i tried 
accessing it directly by typing in the path and it says it cant find it.

Currently, i can access the public directory and my linux home directory. 
If i remove myself from the smb group, i can still see the public directory 
inside network neigborhood, but i cant access it.

However, nothing i do seems to give me access to the test directory. Can 
anyone tell me what i might be doing wrong? What are the steps to making a 
new directory and allowing all samba users access to it? Or for that 
matter, how can i give all samba users the same access permissions they 
would have as if they were logged into the shell? I also tried stopping and 
start smb but it didnt have any effect I could see.


More information about the samba mailing list