System error 5 has occurred.

Thomas Mercer-Hursh, Ph.D. thomas at
Fri Sep 15 00:13:50 GMT 2000

I am implementing 2.0.7 on a Sun E250 running Solaris 8, the first new 
Samba installation I have tried in many a year.  The binaries built 
flawlessly and, with a bit of tinkering here and there I got through steps 
1 to 7 of the diagnostics just fine.  Step 8, however yields me the 
following from a WinNT 4.0 box:
C:\WINNT\system32>net view \\cisun
System error 5 has occurred.

Access is denied.
Clicking on the workgroup name in the treeview display in Map Network Drive 
(which previously showed me the available shares elsewhere in the network, 
but now has no detail shown), gives me "The account is not authorized to 
login from this station.  I get the same result from trying to map any 
share, regardless or the user name I supply.  The user name on the NT does 
correspond to an account on the Sun, but I have also tried supplying other 
user names and passwords with the same result.  Among the shares I have 
tried mounting are some that are public and which are identical in 
definition to those on an HP-UX system where they work fine.  I am getting 
no error messages or anything else in log.machinename and all I get in 
log.smb is:

   smbd version 2.0.7 started.
   Copyright Andrew Tridgell 1992-1998
[2000/09/14 17:00:26, 1] smbd/files.c:file_init(216)
   file_init: Information only: requested 10000 open files, 1014 are available.

Which I am curious about, but which I doubt is related to the issue.

I have tried:

     hosts allow = 127.

as well as leaving this blank (yes, the machine I am connection from is one 
of these).  I have also tried:

     hosts equiv = /etc/hosts.equiv

which does contain my machine name. Other than adding a couple of shares 
which I wanted, I have made very few changes from the distributed 
smb.conf.default. There are no errors from testparm or smbclient -L

I have grepped about trying to find some reference as to what system error 
5 means.  I am guessing it has something to do with permissions and such, 
but am not sure where to look as telnet, ping, ftp, etc. all work just fine.


Thomas Mercer-Hursh, Ph.D                    email: thomas at
Computing Integrity, Inc.                    sales: 510-233-9329
550 Casey Drive - Cypress Point            support: 510-233-9327
Point Richmond, CA 94801-3751                  fax: 510-233-6950

More information about the samba mailing list