Samba 2.0.7 & HP-UX Installation problem

eric.lou eric.lou at
Wed Jul 19 07:26:39 GMT 2000

hello Peter,

i ran "configure" as root, and i worked on a non-NFS partition (vxfs).   
However that didn't succeed... 
Nevertheless, i would say that i've  worked without NFS installation since the 
beginning, and it may be precisely the problem, because deamons "lockd" & 
"statd" (processes NFS) are still running. Thus it seems to be logical if 
locking (which tries to use "lockd" without NFS) isn't available.   
But in fact, i don't really know where the bug is. 
I have resolved my problem, with a binary HP-UX/samba2-0-7 installation. 
Thank you anyway ;-)


>> checking configure summary
>> ERROR: No locking available. Running Samba would be unsafe
>> configure: error: summary failure. Aborting config
>This is the classic symptom of needing to run configure as root.  I
>don't understand quite why, but some locking tests apparently fail if
>you aren't root.  This hasn't happened to me yet, but it's been
>reported by quite a few other people.
>Oh.  Also, if the error persists, try configuring samba on a non-NFS
>partition.  Then if that succeeds, try to arrange not to share any
>filesystems you are getting via NFS.

More information about the samba mailing list