John LeMay jlemay at
Thu Sep 9 02:48:33 GMT 1999

I would bet you had another problem or a bad hub. Point is, this is a
hub. What you descibe in your note would be a layer 3 switch (aka
bridge). I see absolutely nothing on their site that describes any layer
3 functionality (or even layer 2) that is built into this hub. A good
indicator would be price. I know of no devices that perform L3 tasks
that are priced below $1000 (roughly). What does the SOHO go for?

Is it possible something was set at, for example, 10/HDX when it should
have been 100/FDX? Could you possibly have been using the mdix
(crossover) port when you tested IP and switched the cable to a straight
through port when you tried 'beui?

Jon Griffin wrote:
> I just ran into a completely unexpected problem.
> It appears that the Kingston SOHO Hubs don't do TCP. They do NETBEUI very
> well. After 4 hours of troubleshooting I went home and got my cheap Bay
> Networks 8 port hub and everything worked.
> This is to hopefully prevent others from running into the same problem.
> Nothing on Kingstons site mentions no TCP support but swapping only the hub
> worked perfectly. If anyone has more insight or other hubs that don't work
> please let me know.
> Thanks,
> Jon Griffin
> jong at
> Check out:
> <>
> <>

John J. LeMay Jr.

More information about the samba mailing list