newbie problems

Nikolaj Farrell nikk at
Sun Nov 21 20:09:01 GMT 1999

I am running samba-2.0.3-13 on linux 2.2.7 (SuSE6.1). Me and my two neighbors
decided to setup a local network. Both my friends run win98. First I set up the
smb.conf file and let my one neighbor run the Win98_PlainPassword.reg. He then
rebooted his win-box and clicked on network neighbourhood. Everything worked
perfectly, i.e. he could browse my shared files. Then he closed network
neighbourhood and reopened it. My linux box was nowhere to be found! At the
DOS-prompt I typed in "net use x: //linuxbox". Still didn't work, but now we
could, if we erased "network neighbourhood" in the win-browser and typed in
//linuxbox, browse the linuxbox. The odd thing is that the exact same thing
happened when we tried to hook up my other neighbours computer. i.e it worked
the first time but then didn't. Furthermore I can't get access from my linuxbox
to any of the win boxes. There are no passwords set on the shared files, still
when I try 'smbclient \\\\windowsbox\\' I get an error message;

Added interface ip= bcast= nmask=
Password:  (here i just punched enter)
tree connect failed: ERRSRV - ERRinvnetname (
Invalid network name in tree connect.).

I can't see any mistakes in network names, but then again I am no wiz.
'smbclient -L winbox' works fine and gives me a nice list of info about the

Any ideas where I have gone wrong? I am about to give up so any information
except RTFM will be received with great joy. 

Nikolaj Farrell
nikk at

More information about the samba mailing list