samba-2.0.6 configure on solaris 2.6

Gary.Ross at Gary.Ross at
Wed Nov 17 15:53:31 GMT 1999

Hi there all,

I am trying to compile samba-2.0.6 in Solaris 2.6 on a SPARC processor.

Running configure gives the following error:
     checking for fcntl locking... no
     checking for broken (glibc2.1/x86) 64 bit fcntl locking... no
     checking for 64 bit fcntl locking... no
     checking configure summary
     ERROR: No locking available. Running Samba would be unsafe
     configure: error: summary failure. Aborting config

I found three samba list messages from late august.
One with the problem on in HPUX.
The other two related to automounted directories on Solaris which autoconf
was unable to use.
I ran configure in /tmp and another filesystem not automounted but received
 the same error.

I've successfully compiled, installed, and configured samba-1.9 but that
did not use autoconf.
We're presently running samba-2.0 but that was installed from precompiled
I'm attempting to upgrade to the latest version.

Any assistance would be greatly appreciated.

Gary Ross

Disclaimer: This message is not intended to be legally binding and no
liability is accepted for any action in reliance on its contents.
Securicor Omega Express Limited
Registered Office:
Sutton Park House,
15 Carshalton Road,
Surrey  SM1 4LD.
Registered in England No: 2275780
Tel: +44 (0)181 770 7000
Fax: +44 (0)181 643 1059

More information about the samba mailing list