strange share violation

Marek Les marek at
Fri Jul 23 07:17:19 GMT 1999

hello there !

I have one problem. We have a catalogue on a CD which is being used
frequently so it's copied on a Novell network. But now we have to move
it on a Samba box. But when two (or more) users try to run it, the
second user (and all the rest) gets a message that the program
couldn't access one file. The first user runs it perfectly.

Here is a snippet from a log file:


[1999/07/19 18:19:11, 2] smbd/open.c:check_share_mode(742)

Share violation on file 
(0,4,2,901,common/Katalogy/AVNet99/SES_DATA/SESDATA.DDB,fcbopen = 0, 
flags = 0) = 0  


I don't know what's wrong.. I tried to set Locking to No with no
success.. I tried Fake Oplock with no success..

The _interesting_ thing is that on Novell it had the same problem but
the solution was to set the files with the flag SHAREABLE ("flag *
sh") !

Now IMHO nothing equal exists on Linux.. so, please could you help me

I'm running Linux 2.2.10-ac5, Samba 2.0.4b (from Rawhide) ..

btw: I have no problem with more users reading the same file, just
with this catalogue program..

thanks in advance!

Marek Les

More information about the samba mailing list