strange share violation

Robert Dahlem Robert.Dahlem at
Sun Jul 25 08:55:14 GMT 1999


On Fri, 23 Jul 1999 17:18:11 +1000, Marek Les wrote:

>I have one problem. We have a catalogue on a CD which is being used
>frequently so it's copied on a Novell network. But now we have to move
>it on a Samba box. But when two (or more) users try to run it, the
>second user (and all the rest) gets a message that the program
>couldn't access one file. The first user runs it perfectly.


>I don't know what's wrong.. I tried to set Locking to No with no
>success.. I tried Fake Oplock with no success..

Are you sure you had smbd re-read smb.conf? When doing changes to smb.conf you 
should identify the connected smbd son by running smbstatus and kill it.

>The _interesting_ thing is that on Novell it had the same problem but
>the solution was to set the files with the flag SHAREABLE ("flag *
>sh") !

Try to put this catalogue into its own share and make that share read-only.


Robert.Dahlem at
Radio Bornheim - 2:2461/332 at fidonet +49-69-4930830  (ZyX, V34)
                 2:2461/326 at fidonet +49-69-94414444 (ISDN X.75)

More information about the samba mailing list