HELP NEEDED: Problems with Samba 1.9.18p10 + Solaris 2.5.1 + Win95

Guy Dallaire gdallaire at
Tue Feb 16 04:47:50 GMT 1999


I've just installed samba under Solaris 2.5.1. I got the binary package from a legitimate samba mirror site.  I'm having a LOT of problems to get it working. I once used samba on a Digital Unix machine without any problem but it seems a bit different under solaris. I would really like to have it working as it would help my developpers a LOT.

Here are the symptoms/problems:

I have no problem seeing the shares from win 95 (OSR2+VREDIR update) network neighborhood. When I connect a drive, I can see the directories but the names are not in the correct case, for example, UNIX BII directory becomes Bii under windows. I could live with that.

I have the minimal smb.conf file and it was checked with testparm. It looks like this:

delete readonly = yes

path = /disk9/dev
writeable = yes
comment = developpement
create mask = 0775

When I try to access a file or a subdirectory under the share, I get a message telling me "File not found", or "this folder does not exist".

I tried all sorts of upper/lower, preserve, case combinations in smb.conf, nothing seems to work. I tried with debug level = 3 and I noticed a lot of "Error file not found, line=..." in the samba log.

If I use "make new folder" from Windows explorer, it creates a "New folder" directory but I cannot access it ! It say "the directory does not exist"

I even tried setting all UNIX permissions on the shared directory branch and subdirs to 777 but that did not help.

Any idea ?

More questions:

a) Can samba + win 95 be configured in such a way that if files AAA.dat, AaA.dat, aaa.dat exist under UNIX, I will be able to distinguish between the three files under win 95 ?
b) Do I really need solaris 2.6 to run samba 2.02 or I will only miss the the Web admin tool ?
c) Should I try to build samba to fix my preblem ? If so, where can I get the sources for an older version ?
d) Did anyone successfuly run samba in a solaris 2.5.1 machine + win 95 ? Am I wasting my time ?
e) I want all my different users (they all belong to the same UNIX group) to be able to read/write all the files and directories under the shared directory. Under UNIX, they can do it (sometimes, they will get a message telling them: override protection 0xxx for file yyy ?) but I want samba to "answer" yes automagically to that kind of prompt. Is it feasible and if not, what should I do to permit that kind of team work ?

Thanks for your time

-------------- next part --------------
HTML attachment scrubbed and removed

More information about the samba mailing list