W95 password change

Gerald W. Carter cartegw at eng.auburn.edu
Tue Oct 28 16:24:59 GMT 1997

>         But when a W95 station tries to change its network password from
> the control panel, I'v got various answers like "not enough memory"
> (???), "unknown user" ... When the NT stations are off, the answer is 
> that the network doesn't provide this service. In all cases, I tried to
> log the API calls received by samba, and it _never_ received the 115
> (SetUserPassword) request. From a DOS box, the NET PASSWORD is not
> allowed ...

'net password \\server' will work from a DOS prompt.  Actually the
commend will execute but give an error message.

I believe that the problem is really the way that Windows 95 transmits
the password ( both old and new )....in UPPER case.  Even with a
password level parameter parameter in smb.conf, samba may be able to
matche the old password but how can it know what the case was in the new
password?  I think you can get this to work from NT but not from 95.

Has anyone ever got the password change thing worked out from a Win95

Have you done a packet dump and looked at what is going across the wire?

                          Gerald ( Jerry ) Carter	
Engineering Network Services                           Auburn University 
jerry at eng.auburn.edu             http://www.eng.auburn.edu/users/cartegw

       "...a hundred billion castaways looking for a home."
                                  - Sting "Message in a Bottle" ( 1979 )

More information about the samba mailing list