NT Workstation can not access shares

Luke Kenneth Casson Leighton lkcl at switchboard.net
Tue Nov 18 14:09:03 GMT 1997

On Tue, 18 Nov 1997, Dave wrote:

>   This is an NT, not SAMBA, problem, but I don't know who else to ask.

hi dave,

it's an NT->Samba interaction issue, which makes it our problem to deal 

my first suggestion to you would be to compile up 1.9.17p4, but not to
overwrite your 1.9.16p11 installation with it.  this is because 16p11 is
quite old (relatively speaking - i have a goldfish / context-sensitive memory
that forgets things in a couple of days...) but you don't want to disrupt 
your installation should you get the NT portable back exactly as it was.

then run 1.9.17p4 with the same smb.conf you use on 16p11, see what happens. 

if that fails, then run with a high debug level, and examine the log.smb 
file for SMBsesssetupX's and error messages.  basically, see the docs 
directory DIAGNOSIS.txt and BUGS.txt files for suggestions.

please keep in touch, and let us know how you get on.



> Details at end.
>   This client tries to access their home directory, and a dialog box pops
> up titled -
>   = Enter Network Password =========================================
>  |                                                                  |
>  |     Incorrect password or unknown username for:          <  OK  >|
>  |        \\unixmachine\home                                <Cancel>|
>  | Connect As: ________________________________             < Help >|
>  | Password:   ________________________________                     |
>   ------------------------------------------------------------------
>   Last week, you could enter a valid username and password and get access,
> this week I get :
>   ==== \\unixmachine\home ========================================
>  |                                                                |
>  | \/       \\unixmachine\home is not accessible                  |
>  | /\  The account is not authorized to login from this station.  |
>  |                                                                |
>   ----------------------------------------------------------------
>   What's up with this???
>   This account worked fine last week. The account is still usable from a
> Win95 machine without any problems. Last week, this laptop died, and had to
> have NT reloaded from scratch. Now this laptop can not access the SAMBA
> shares that have share level security. All other TCP/IP stuff works fine,
> and you can access the SAMBA shares that don't have any restrictions on them.
>   Where on the workstation do I look? What is turned on that should be off?
> Remember: THIS WORKED UNTIL THE LAPTOP DIED. I didn't change anything on
> the SAMBA server.
>   This is a laptop with NT 4.0 workstation. Last week, it was the base
> install of NT, this week it is the same base install + Service Pack 3.
>   Only one network protocol - TCP/IP
>   5 Services - Computer Browser, NetBIOS Interface, RPC Configuration,
> Server & Workstation.
>   If you look under the Identification, the computer name is DAVE-NB and
> the workgroup is WORKGROUP, there is noplace to enter a domain. Under the
> <Change...> button, the only thing checked is "Member of: Workgroup :
>   There are NO NT servers anywhere on this network, only SAMBA machines
> acking as file servers.
>   The UNIX server hasn't changed. I am using SAMBA 1.9.16p11. If there is
> security, it is share level security, not server level.
>   Please send email and I will try to follow the digest.
> dburwell at telecom.com

<a href="mailto:lkcl at switchboard.net"  > Luke Kenneth Casson Leighton  </a>
<a href="http://mailhost.cb1.com/~lkcl"> Samba Consultancy and Support </a>

More information about the samba mailing list