samba-1.9.18alpha13 compiling on Linux

Ken Seitz ken at
Sun Dec 21 20:42:01 GMT 1997

Happy holidays!

Has anyone experienced problems getting 1.918alpha13 to compile under
Linux?  I am running the 2.0.32 kernel on the Slackware-3.4 distribution
(shadow password file, no quota).  Below are the results of a make:

Using CFLAGS = -O -DSMBLOGFILE="/var/adm/smbd.log"
og" -DCONFIGFILE="/etc/smb.conf" -DLMHOSTSFILE="/etc/lmhosts"
ocal/samba" -DLOCKDIR="/usr/local/samba/var/locks"
n/smbrun" -DCODEPAGEDIR="/usr/local/samba/lib/codepages"
DGUEST_ACCOUNT="nobody" -DDRIVERFILE="/usr/local/samba/lib/printers.def"
Using LIBS =  -lshadow
Compiling smbpass.c
gcc: Internal compiler error: program cc1 got fatal signal 6
make: *** [smbpass.o] Error 1

As you can see, my compiler just dies.  There are no errors in the
compilation until smbpass.c.  I'm not really sure where to go from here
with the problem.  My Linux installation is less than a month old, so my
libraries and compilers are current.  I have not experienced compiler
problems with any other programs.  I have tried several other of the
1.9.18 alpha's with the same result, yet 1.9.17 compiles cleanly.  

If anyone has suggestions, they would be greatly appreciated!   Please
let me know if further details are required.

On a more cheerful note... my two OSF/1 boxes are working very well with
the new version, and I have no problems to report.

Ken Seitz
   - DRA Network Associate
   - ken at

More information about the samba mailing list