problems with "Save As" in BNA Income Tax Planner for Windows

Joshua Heling jrh at
Wed Dec 3 23:01:14 GMT 1997

Hi -

A client reported this morning that the "Save As" function in some tax 
planning software they use "didn't work with the new server" (Samba 1.9.17p2 
on intel/linux v 2.0.30).  All client machines are Win95 OSR2.

Essentially, when you type a name in the save as dialog and press enter, a 
backslash is added to the end of the new filename (in the dialog, that is), 
there is a brief pause, and the name is replaced by the standard windows 
dialog box extension filter, which in this case is '*.it*'.  There is no error 
message, the user is still looking at the save as dialog box, and no new file 
is created.

This behavior was observed on any networked samba drives at the client's 
office, and I have repeated it (many times) in my office on both 1.9.17p2 and 
1.9.18alpha12.  Doing a "save as" to a local drive works without any problem.

I've gathered logs at debug levels 3, 4, and 5.  I am not able to get any 
useful information from them myself, but I did find the few lines logged right 
before the error occurred to be interesting ("NEWFILE.IT" is the file I'm 

- - - start log snippet - - - 
12/03/97 16:29:46 Transaction 1201 of length 41
switch message SMBfindclose (pid 14533)
reply_findclose, cnum = 87, dptr_num = 14
12/03/97 16:29:46 SMBfindclose cnum=87, dptr_num = 14
12/03/97 16:29:46 Transaction 1202 of length 100
switch message SMBtrans2 (pid 14533)
call_trans2findfirst: dirtype = 0, maxentries = 6, close_after_first=0, 
_end = 0 requires_resume_key = 0 level = 260, max_data_bytes = 2432
unix_clean_name [./NEWFILE.IT/*.IT*]
unix_clean_name [NEWFILE.IT/*.IT*]
unix_clean_name [NEWFILE.IT]
12/03/97 16:29:46 error packet at line 644 cmd=50 (SMBtrans2) eclass=1 ecode=3
error string = No such file or directory
chdir to /var/log
- - - end log - - -

"No such file or directory" ??? Well, no, there shouldn't be one, as I'm 
trying to save as a new file!  This is with fairly standard configuration 
settings, significant globals are 'short preserve case' and 'preserve case' 
both yes, 'locking' and 'share modes' both yes.  Service params are:

   browseable = yes
   writeable = yes
   public = no
   ;; everything is done by the users group -- allows sharing
   force group = users
   force create mode = 0664
   force directory mode = 0775

Thinking that perhaps the problem was related to name mangling, I tried adding 
the following mangling-related parameters, but to no avail:

	mangle case = no
	case sensitive = no
	default case = upper
	preserve case = no
	short preserve case = no

I also tried setting "strict locking" and even "fake oplocks", but neither 
worked.  While I haven't yet tried 1.9.18alpha12 on a raised debug level, it 
does appear to have the same problem.

Can anyone shed some light on this problem?  I haven't included the debug logs 
for the sake of space, but will happily send them to anyone who wants more 
info.  This is a rather severe issue for the client, and is unfortunately 
coming immediately after their conversion from Novell (in which the app worked 
fine.. :( )



Joshua Heling				             jrh at
SecurePipe Communications, Inc.

More information about the samba mailing list