Running samba and smbd processes together

Anoop Singh anoop.singh at
Mon Sep 21 06:21:43 UTC 2015

Hi Mac,

Thanks a lot for the help.
I did 'ps' for samba. It gives me pid of one parent and 11-12 child processes.
When I did ps for 'smbd' specifically, I don't get any pid as "smbd" is not running. Looks like samba is not starting smbd. Do I need to configure something?
Also I want to share a directory by using the below mentioned smb.conf file which works as domain controller as well as file share.

# Global parameters
guest ok = yes
workgroup = TEST
realm = TEST.COM
netbios name = DC1
server role = active directory domain controller
server services = rpc, nbt, wrepl, ldap, cldap, kdc, drepl, winbind, ntp_signd, kcc, dnsupdate, dns, smb
dcerpc endpoint servers = epmapper, wkssvc, rpcecho, samr, netlogon, lsarpc, spoolss, drsuapi, dssetup, unixinfo, browser, eventlog6, backupkey, dnsserver, winreg, srvsvc
idmap_ldb:use rfc2307 = yes

path = /var/lib/samba/sysvol/
read only = No

path = /var/lib/samba/sysvol
read only = No

path = /usr/dir_anoop
browseable = yes
guest ok = yes
writable = yes
available = yes
public = yes
create mask = 0755

Please let me know if you find any issue.

Thanks & regards,

-----Original Message-----
From: Marc Muehlfeld [mailto:mmuehlfeld at]
Sent: Monday, September 21, 2015 11:37 AM
To: Anoop Singh; samba-technical at
Subject: Re: Running samba and smbd processes together

Hello Anoop,

Am 21.09.2015 um 07:12 schrieb Anoop Singh:
> I also want to use samba for file sharing along with working as domain
> controller. For this I need to run "smbd".
> In my Ubuntu machine if I run "samba", "smbd" does not run.
> If I run "smbd" manually, it doesn't start and I get log as " You
> should start samba instead, it will control starting smbd if
> required".

'samba' start 'smbd' processes automatically as child-processes. See output of 'ps'.

If you want to configure additional shares on your DC, just follow

> I read that when samba is running as Domain Controller it is not
> recommended to use as file server. Could anybody please let me know
> what is the reason?



DISCLAIMER: This electronic message and any attachments to this electronic message is intended for the exclusive use of the addressee(s) named herein and may contain legally privileged and confidential information. It is the property of Celstream Technologies Private Limited. If you are not the intended recipient, you are hereby strictly notified not to copy, forward, distribute or use this message or any attachments thereto. If you have received this message in error, please delete it and all copies thereof, from your system and notify the sender at Celstream Technologies or administrator at immediately.

More information about the samba-technical mailing list