Samba 3.X on ZFS with acl_xattr / acl_tdb

Richard Sharpe realrichardsharpe at
Tue Oct 8 07:26:01 MDT 2013

On Tue, Oct 8, 2013 at 5:27 AM, Hafeez Bana <hafeez.bana at> wrote:
> Hi Everyone,
> I've been trialling ZFS with Samba 3.x (Ubuntu 12.04) and everything works
> OK except when you try to assign permissions using Windows 7 and using the
> acl_xattr or acl_tdb scheme.
> One keeps getting 'Access Denied'.

Have you tried getting a level-10 debug log to see why you are getting
access denied? You might want a capture as well so you can find the
exact point at which you are getting the EACCESS.

> the same config except on an EXT4 system works flawlessly.  ZFS already
> supports xattrs so I am not sure what else ZFS needs to support for Samba
> with acl_xattr to work.
> It's strange that acl_tdb also exhibits the same error because one would
> have thought the acls would be written to a tdb file.
> Any insights would be appreciated. The only thread I have been able to find
> is this one
> But again I fail to understand how that has an impact, particularly when
> using acl_tdb
> Thx.
> Hafeez

Richard Sharpe

More information about the samba-technical mailing list