Samba4 AD up and running

Paul Macdonnell pgmac at
Sun Feb 10 00:29:24 MST 2013

On Sun, Feb 10, 2013 at 4:44 PM, Andrew Bartlett <abartlet at> wrote:

> On Sun, 2013-02-10 at 12:18 +1000, Paul Macdonnell wrote:
> > Hi all,
> > I just got my first Samba4 AD DC up and running on Ubuntu 11.04 using the
> > HOWTO wiki page (built from tarball sources):
> >
> >
> > Just wanted to say thanks for providing a great intro into getting it all
> > up and running.
> > I ran into a couple of other issues along the way, but that's because I
> was
> > installing on to an already running system.
> > I run some virtuals on the server in questions, so dnsmasq (running on
> the
> > other virtual interfaces) got in the way of the samba dns server
> starting.
> >  Once I got past that, it's come up quite nicely.
> Great!

I'm really excited about getting this going.  It's brilliant to have an

> > I do have an issue where my win7 virtual was able to successfully join
> the
> > domain and install the AD management tools, but it isn't showing the
> > "Active Directory User and Computers" snap-in.  I'm also unable to run it
> > via Start -> Run -> dsa.msc.
> >
> > Do you have any clues, or hints, for me to further chase this up?
> So, to be clear, you installed the remote server admin tools from here:


But you just can't make them start?

I had a good delve around in there and the dsa.msc snap-in didn't exist in
C:\Windows\system32\ at all.

So, I had look through the "Turn Windows features on or off" in "Programs"
in the Control Panel.
I found all of the items in there and was able to install everything (and
more) that I needed.
So, I do now have access to the "Active Directory User and Computers", plus
all other AD/Group policy/DNS/DHCP/etc management snap-ins.

My next problem now, is that I'm not having my profiles sync'd back to the
server again.
I created /usr/local/samba/var/profiles directory and set the Profile path
for all users, according to the wiki instructions.
There's nothing coming through in the log.samba, or log.smbd log files, to
suggest the nature of the problem either.
When I log in as a user (either "my" user, or the Administrator), it says
it's unable to access the profiles share AND unable to create a temporary
profile on the PC.
The user I created has the same group memberships as the "Administrator".
 Could this be causing the problem?
I also ran up a Windows XP virtual, which is experiencing the same problem.


More information about the samba-technical mailing list