RPC Error - Samba 4

Andrew Bartlett abartlet at samba.org
Sun May 27 19:19:48 MDT 2012

On Fri, 2012-05-25 at 15:42 -0400, Ryan Whelan wrote:
> I'm not sure if this is correct place for this- if not, forgive me.
> I followed the how-to to setup samba 4 (Version 4.0.0alpha22-GIT-e17fa58)
> as a PDC.  I added a windows XP machine to the domain and created a share
> on the new PDC machine (share called C$ if that matters).
> On the XP client, i right click on "My Computer" and click on "Mange".
> When the MMC opens, I right click on the top of the tree, and select
> "Connect to another computer".  In the field, I type in the hostname of the
> new PDC and it connects immediately.
> When I expand "System Tools" -> "Shared Folders" and select "Shares" it
> hands for a long time.  Eventually I get an error - "Error 1723: the RPC
> server is too busy to complete this operation".  When I click OK on the
> error window, the shares show up in the MMC just fine and i am able to
> adjust permissions etc.
> Looking at the log.smbd, it is just flooded with the same error.
> "[2012/05/25 15:09:45.774726,  0]
> ../source3/rpc_server/rpc_ncacn_np.c:629(make_external_rpc_pipe_p)
> tstream_npa_connect_recv  to /usr/local/samba/var/run/ncalrpc/np for pipe
> MacFile and user SLAM\Administrator failed: No such file or directory". A
> longer sample if helpful is here: http://pastebin.com/cBUD3wiu
> The log file was empty when i started samba- but the above error is in the
> log so many times, the file is over 2.5Mb after it finally errors out.
> Is this a misconfiguration on my part?  The path
> /usr/local/samba/var/run/ncalrpc/np DOES exist and is a dir.  It is full of
> socket files.

This isn't a misconfiguration, just the kind of extra thing we need to
learn about with the new default 's3fs' configuration. 

We should regard the failure to find the MacFile pipe (which we have
never heard of) as in the same way we have rejected invalid pipe names
in the past.  Clearly we don't get that right.

If you want to look into it more, you could look at the code in
source3/rpc_server/rpc_ncacn_np.c and a network trace, and see if you
can make it return a different error - for example, the same error
Samba4 would give if not running in s3fs mode (comment out the 'server
services' line and dcerpc endpoints lines in your smb.conf), or an AD
server gives (if it also doesn't implement MacFile).

Andrew Bartlett

Andrew Bartlett                                http://samba.org/~abartlet/
Authentication Developer, Samba Team           http://samba.org

More information about the samba-technical mailing list