Samba4 experiences

Dirk Gouders gouders at
Fri Sep 16 01:52:54 MDT 2011

Dirk Gouders <gouders at> writes:

> Dirk Gouders <gouders at> writes:
>> * winbind behaves a bit strange on the 3.6 side.  Only the group name is
>>   not shown correctly, maybe due to a misconfiguration:
>>   $ id dgouders
>>   uid=1632(FB5+dgouders) gid=1013(TANGO+none) groups=1013(TANGO+none)
>>   I already sent a message to samba@ and maybe this problem will be
>>   solved, soon.
> After I added the user to another group with simo's help, two new groups
> are showing up on the samba 3.6 side with the correct name (meanwhile I
> enabled 'winbind use default domain', so the FB5+ part has gone):
> $ id dgouders
> uid=1632(dgouders) gid=1013(TANGO+none) groups=1013(TANGO+none),1012(domain admins),1072(denied rodc password replication group)
> Could it be that there is some information left in a local tdb file that
> causes this?

Problem solved(the rough way): after sleeping a night over it, I came to
the conclusion that the above thought might be the one and only
possibility.  Because I already tried to remove winbind_cache.tdb and
group_mapping.tdb which did not help, I removed every tdb and dat file,
rejoined the domain and now the correct group names are displayed.

I still have the output of winbindd started with "-d 10" and an strace
output of winbindd should someone be interested.

Thanks again to Simo: becoming a member of an additional group helped me
a lot with diagnosis.


More information about the samba-technical mailing list