running wintest issues

Andrew Bartlett abartlet at
Mon Oct 3 18:44:46 MDT 2011

On Mon, 2011-10-03 at 17:01 -0400, Sean Dague wrote:
> After the changes to the wintest script to move the samba-tool path to 
> sbin (patch previously on list) I've been able to get the basic Windows 
> 7 test to run, though I'm still fighting a bit with the win2k8 testing.

This is a bit fishy.  if it is expected to run from the install dir,
then I guess it should run without a bin/ or sbin/.  I think the bin/
was for running from the build dir.

> I ran across a few things in the process:
> 1) wintest doesn't work with Bind 9.7.3 in Ubuntu 11.04 (I couldn't get 
> it to work even though it worked fine for manual testing). It really 
> needs bind 9.8.x. Should that just be made an early prereq of the tests?

I think so. 

> 2) it looks like for the win2k8b tests the Answers file for the dcpromo 
> command isn't getting the password, at least when I look at the file 
> afterwards, it isn't there. Is this something that's hidden 
> automatically, or is there actually something wrong with the command 
> sending?

The missing password is a red herring, dcpromo removes it from the file
to avoid it being left on disk.

> Also, the litteral ^Z in the console, could that be causing issues, or 
> is that expected?
> Nudges in the right direction would be appreciated.

What exactly is the problem you face?  What goes wrong with dcpromo?

It's really good to see someone having a go at wintest.  It is a really
important testsuite, but sadly it hasn't had many users and is a little
fiddly to get going.

Andrew Bartlett
Andrew Bartlett                      
Authentication Developer, Samba Team 

More information about the samba-technical mailing list