running wintest issues

Sean Dague sdague at
Mon Oct 3 15:01:03 MDT 2011

After the changes to the wintest script to move the samba-tool path to 
sbin (patch previously on list) I've been able to get the basic Windows 
7 test to run, though I'm still fighting a bit with the win2k8 testing.

I ran across a few things in the process:

1) wintest doesn't work with Bind 9.7.3 in Ubuntu 11.04 (I couldn't get 
it to work even though it worked fine for manual testing). It really 
needs bind 9.8.x. Should that just be made an early prereq of the tests?

2) it looks like for the win2k8b tests the Answers file for the dcpromo 
command isn't getting the password, at least when I look at the file 
afterwards, it isn't there. Is this something that's hidden 
automatically, or is there actually something wrong with the command 

Also, the litteral ^Z in the console, could that be causing issues, or 
is that expected?

Nudges in the right direction would be appreciated.


Sean Dague
IBM Linux Technology Center
email: sldague at
alt-email: sdague at

More information about the samba-technical mailing list