[SOLVED] Re: Samba 4.0 DNS configuration

Trever L. Adams trever.adams at gmail.com
Tue Jul 26 11:10:32 MDT 2011

On 07/08/2011 01:39 AM, Trever L. Adams wrote:
> On 07/07/2011 12:13 AM, Andrew Bartlett wrote:
>> The issue here is that the name that nsupdate requests a ticket to is
>> not in Samba's sam.ldb.  As I mentioned in my previous mail, this name
>> is derived from that first line (the SOA) of the zone.  
>> Can you look there and see how it differs from your working servers?
>> Did you upgrade to BIND 9.8?
>> Thanks,
>> Andrew Bartlett

If any one else has a problem with moving S4 forward from old installs
and suddenly has problems with dns updates not working. There are many
different issues. If you follow all the suggestions in this thread and
the problem doesn't resolve, check the machine account for the domain
controller (not the dns-CONTROLLER account) for a servicePrincipalName:
DNS/ line. If it exists, it is probably the problem. I do not know how
it came to be there in my domain, but removing it solved the problem as
the dns-CONTROLLER account had been properly created by the
upgradeprovision script.

Just a heads up in case anyone else finds themselves in this odd
situation. Thank you to all who helped track this down.

"The hands that help are better far than the lips that pray." -- Robert
G. Ingersoll

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 261 bytes
Desc: OpenPGP digital signature
URL: <http://lists.samba.org/pipermail/samba-technical/attachments/20110726/f787ab07/attachment.pgp>

More information about the samba-technical mailing list