dcerpc_register_ep_server missing in installed libs

Julien Kerihuel j.kerihuel at openchange.org
Mon Jun 14 06:37:45 MDT 2010

On Mon, 2010-06-14 at 13:06 +0200, Julien Kerihuel wrote:
> It still doesn't work but I have not yet figured out why yet. Maybe just
> a pointer, the problem occurs when we run samba process when it tries to
> load our dcerpc_server/dcesrv_mapiproxy.so within samba.
> Could this be related to the way samba4 now loads external modules?

At samba startup, we have:

samba:using 'signle' process model
Unable to
open /usr/local/samba/modules/dcerpc_server/dcesrv_mapiproxy.so: /usr/local/samba/modules/dcerpc_server/dcesrv_mapiproxy.so: undefined symbol: dcerpc_register_ep_server
DCERPC endpoint server 'rpcecho' registered
dcesrv_init_context: failed to find endpoint server = 'mapiproxy'
task_server_terminate: [Failed to startup dcerpc server task]
samba_terminate: Failed to statup dcerpc server task

After some gdb and trace, I finally came to param/utils.c and the
load_module function where dlopen is called and returns the 'undefined
error' posted above.

It sounds like samba binary symbols are not exported / made public and
available to subsequent DSO opened with dlopen.

I tried to add -rdynamic flag both as a compilation flag and for gcc
binary linkage, but no success so far.

Julien Kerihuel
j.kerihuel at openchange.org
OpenChange Project Manager

GPG Fingerprint: 0B55 783D A781 6329 108A  B609 7EF6 FE11 A35F 1F79

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 197 bytes
Desc: This is a digitally signed message part
URL: <http://lists.samba.org/pipermail/samba-technical/attachments/20100614/b1e24d64/attachment.pgp>

More information about the samba-technical mailing list