dcerpc_register_ep_server missing in installed libs

Girish V girish.server at gmail.com
Tue Jun 15 23:43:00 MDT 2010

On Mon, Jun 14, 2010 at 6:07 PM, Julien Kerihuel
<j.kerihuel at openchange.org> wrote:
> On Mon, 2010-06-14 at 13:06 +0200, Julien Kerihuel wrote:
>> It still doesn't work but I have not yet figured out why yet. Maybe just
>> a pointer, the problem occurs when we run samba process when it tries to
>> load our dcerpc_server/dcesrv_mapiproxy.so within samba.
>> Could this be related to the way samba4 now loads external modules?
> At samba startup, we have:
> samba:using 'signle' process model
> Unable to
> open /usr/local/samba/modules/dcerpc_server/dcesrv_mapiproxy.so: /usr/local/samba/modules/dcerpc_server/dcesrv_mapiproxy.so: undefined symbol: dcerpc_register_ep_server
> DCERPC endpoint server 'rpcecho' registered
> [...]
> dcesrv_init_context: failed to find endpoint server = 'mapiproxy'
> task_server_terminate: [Failed to startup dcerpc server task]
> samba_terminate: Failed to statup dcerpc server task
> After some gdb and trace, I finally came to param/utils.c and the
> load_module function where dlopen is called and returns the 'undefined
> error' posted above.
> It sounds like samba binary symbols are not exported / made public and
> available to subsequent DSO opened with dlopen.
> I tried to add -rdynamic flag both as a compilation flag and for gcc
> binary linkage, but no success so far.

Dear Julien,

Is there a way I could help you with this?


More information about the samba-technical mailing list