solved: Problem using CP850 with samba-3.0.4

Michael Collin Nielsen michael at
Wed Jul 21 17:35:31 GMT 2004

Richard Sharpe wrote:
> On Wed, 21 Jul 2004, Michael Collin Nielsen wrote:
>>>>I came to the conclusion that the libiconv, that I supplied when I ran
>>>>configure wasn't used... config.log showed that the shared library
>>>>couldn't be loaded by the configure script. The configure only adds a -L
>>>>libiconv-path not a -R libiconv-path, therefore all the tests failed. I
>>>>added a LDFLAGS=-R/path/to/libiconv/lib, and now configure is able to do
>>>>the conversions :-)
>>>Hmmm, but this suggests that configure failed to do the right thing?
>>>Perhaps it should be fixed. What was the path to libiconv?
>>My configure-line looks like this:
>>LDFLAGS=-R/pack/libiconv-1.9.1/lib/ ./configure
>>--prefix=/pack/samba-3.0.4 --with-readline --with-automount
>>--with-syslog --with-quotas --with-acl-support
> OK, is not smart enough to know that if you specify a
> --with-libiconv, the library might be a shared library, and thus, it
> should try -R...
> Actually, it should check for -R for architectures for which it applies,
> anyway.
> It shouldn't be hard to teach it how to do that.

Sounds good - Sounds like you know the right teacher ;-)

> This was Solaris, wasn't it?

Yes, Solaris 8 to be precise using gcc.

I just configured on my production system which is Solaris 9 with 
gcc-3.4.0, it has the same problem.



More information about the samba-technical mailing list