solved: Problem using CP850 with samba-3.0.4

Richard Sharpe rsharpe at
Wed Jul 21 15:37:53 GMT 2004

On Wed, 21 Jul 2004, Michael Collin Nielsen wrote:

> >>I came to the conclusion that the libiconv, that I supplied when I ran
> >>configure wasn't used... config.log showed that the shared library
> >>couldn't be loaded by the configure script. The configure only adds a -L
> >>libiconv-path not a -R libiconv-path, therefore all the tests failed. I
> >>added a LDFLAGS=-R/path/to/libiconv/lib, and now configure is able to do
> >>the conversions :-)
> >
> >
> > Hmmm, but this suggests that configure failed to do the right thing?
> >
> > Perhaps it should be fixed. What was the path to libiconv?
> My configure-line looks like this:
> LDFLAGS=-R/pack/libiconv-1.9.1/lib/ ./configure
> --prefix=/pack/samba-3.0.4 --with-readline --with-automount
> --with-syslog --with-quotas --with-acl-support
> --with-libiconv=/pack/libiconv-1.9.1

OK, is not smart enough to know that if you specify a
--with-libiconv, the library might be a shared library, and thus, it
should try -R...

Actually, it should check for -R for architectures for which it applies,

It shouldn't be hard to teach it how to do that.

This was Solaris, wasn't it?

Richard Sharpe, rsharpe[at], rsharpe[at],

More information about the samba-technical mailing list