Blank Page printing with Samba 3.0

Andrew Bartlett abartlet at
Wed Oct 15 10:21:59 GMT 2003

On Tue, 2003-10-14 at 02:23, Rizzo, John wrote:
> I have Samba 3.0 configured to use cups 1.1.19 as a backend for
> printing.  Samba is acting as an AD member server and only as a print
> server to its clients.  I have over 100 printers configured on this
> system and for some reason a blank page is printed after every print
> job.  I have tried this with several PPD files from both
> as well as from the manufacturer and the same is
> happening.  This doesn't happen when I print directly through cups
> bypassing samba.  Any help would be greatly appreciated as I am hoping
> to replace our current MS printing infrastructure with Samba/CUPS
> shortly and this seems to be the last hurdle to getting everything
> working perfectly.

I had this, until I realised that our printers took postscript, and I
just passed it straight-on.  The printer stopped putting out the extra

I think the issue is related to the windows driver configuration, but it
might be able to be solved when it goes via the ps2ps layer.  The
problem is, many windows postscript drivers bypass that layer.  You
could try the CUPS drivers - which they don't seem to advertise, but I
thinks it's : 

Andrew Bartlett

Andrew Bartlett                                 abartlet at
Manager, Authentication Subsystems, Samba Team  abartlet at
Student Network Administrator, Hawker College   abartlet at
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: This is a digitally signed message part
Url :

More information about the samba-technical mailing list