cannot print using 2.2.3a (2.2.2 worked)

Bernhard Hornung bernhard.hornung at
Sun Feb 10 04:41:09 GMT 2002


Today I tried to upgrade our 2.2.2 samba PDC to 2.2.3a. 

Unfortunately the NT clients are no longer able to print to a samba served 
printer. Switching back to samba 2.2.2 cured the problem.

Some details:
Our samba server is a Red Hat 6.2 Linux box. It is set up as PDC. The printer 
is a HP 4100 and the printer drivers are uploaded to the print$ share.  

When we try to print from any application (we tried notepad and winword), the 
event log of the NT box is filled up with the following messages (translated 
from German)

Print driver HP LaserJet 4100 PCL 6 for Windows NT x86 Version-2 was added or 
or updated. Files:-

The printing application seems to be in an infinite loop which generates the 
entries in the event log - or the machine is so busy generating the log 
entries, that nothing else repsonses. The only way to stop this is to end the 
application by task manager. 

It seems to be normal, that this event log entry is generated once or twice 
during standard operation, because we saw them also with our original NT 

We tried removing the printer driver on the samba server and on the local 
machine, reinstalling everything, but nothing worked. Only when we switched 
back to samba 2.2.2 it was OK. We tried this a couple of times, it was 

Our smb.conf looks like follows (I stripped the things which I consider not 

	workgroup = VPMUC
	domain admin group = +ntadmin
	domain logons = Yes
	printer admin = +ntadmin

	path = /var/spool/samba
	printable = Yes
	browseable = No

	path = /usr/local/samba/printers
	guest ok = Yes
	write list = +ntadmin,root
	force group = ntadmin
	force create mode = 0775
	force directory mode = 0775

Any help would be really appreciated.

- Bernhard

More information about the samba-technical mailing list