oplock break errors in 2.2.6-pre1

Pascal pascal at vmfacility.fr
Wed Aug 7 06:57:02 GMT 2002

Le Mercredi 7 Août 2002 14:51, Fredrik Ohrn a écrit :
> Using 2.2.5 we got a lot or errors in the log matching the description in
> the "SMBtrans2 oplock safety" thread.
> This happens on Word/Excel/PowerPoint documents and the clients are
> running Office 2002 + Windows XP. I have not been able to figure out a way
> to trigger the error on demand.
> I tried out 2.2.6-pre1 from the CVS today just to see if the problem has
> gone away. Unfortunatley it is still there, heres a random pick:
> [2002/08/07 08:23:46, 0, pid=6215] smbd/oplock.c:oplock_break(796)
>   oplock_break: receive_smb timed out after 30 seconds.
>   oplock_break failed for file Emigrar.doc (dev = 811, inode = 4899780,
> file_id = 2). [2002/08/07 08:23:46, 0, pid=6215]
> smbd/oplock.c:oplock_break(868) oplock_break: client failure in oplock
> break in file Emigrar.doc [2002/08/07 08:23:56, 0, pid=6215]
> smbd/reply.c:reply_lockingX(4489) reply_lockingX: Error : oplock break from
> client for fnum = 5109 and no oplock granted on this file (Emigrar.doc).
> I also get a lot of occations with only the first 2 messages, i.e. the
> client doesn't break the lock after the timeout. This also only affects
> Office suite documents.
> On some occations I have been able to match these errors with people who
> are complaining that Word gets sluggish and takes forever to open menus,
> dialogboxes, update the screen etc. I'm not 100% sure that the pehomenon
> is related though.
> Where should I start digging to help debug this?
> Regards,
> Fredrik

I have the same problems with all my samba servers, I think it appears in the 
samba 2.2.x series (I ran 2.2.3a then 2.2.5). Was not noticed in 2.0.7 for 

I have noticed that :
 kernel oplocks = no (on linux servers) as well as 
oplock wait break time = 100 or more 
seems to minimise the frequency of the problems.

I have not found a way to reproduce at will the problem where office document 
refuse to open (this is quite random).

I think that users of samba should report more this kind of problem if we want 
it to be examined by the team in priority.

Another problem:
Sometimes I also have multiple smbds processes for a single share+client, all 
beeing in a fcntl RW lock request wait on locking.tdb because of a single 
smbd holding a fcntl lock there and beeing stuck on an open file (a fifo for 

I have submitted a way to reproduce this smbds locks at will (using fifo on 
the server), and I hope some samba developper will experiment and find what's 
wrong in the lock logic. (watch subject: smbd blocking in receive_smb (how to 
trigger procedure - LONG)


More information about the samba-technical mailing list