Procedure Number is IN Range!!

Tony Nelson tnelson at
Thu May 31 15:27:38 GMT 2001

I compiled the latest 2.2 branch myself yesterday.. and used your config as
a jumping off point.. For now I'm only testing w/ a 98 machine.. I'll save
2k until I am sure I have a solid working env... I can now login to my
domain with the following caveats...

   1) I can't see any shares or use network neighborhood
   2) If I log off the 98 machine, I can't log in again unless I reboot..
   3) My login script does seem to run, but it doesn't seem to work.. it's a
      big two lines... 'echo some stuff' 'pause'  .. I wrote the file on the
      98 box and ftp'd it in bin mode to make sure I had DOS cr/lf pairs...
      but I always seem to get the effect of .. echo 'some stuff   pause'

My ultimate goal is just to be able to share a few disks from the big
machine upstairs and it's printer on my tiny home network (me, my wife, and
the cats)...

Thanks for any help..

Here is my current config:

# Global parameters
        os level = 65
        preferred master = yes
        local master = yes
        domain master = yes
        logon drive = H:
        logon home = \\tonikfw\%U\profile
        logon path = \\tonikfw\%U\profile
        security = user
        workgroup = NELSONNET
        encrypt passwords = yes
        domain logons = Yes
        logon script = scripts\%U.bat
        domain admin group = @adm
        add user script = /usr/sbin/adduser -n -g machines -c Machine -d
ll -s /bin/false %m$
        guest account = ftp
        share modes = no
        netbios name = TONIKFW
        server string = samba %h %v
        interfaces =
        password level = 4
        username level = 4
        wins support = Yes
        deadtime = 15
        name resolve order = wins lmhosts host bcast
        hosts allow = 192.168.45. localhost
        read only = No
        create mask = 0700
        directory mask = 0700
        browseable = Yes

        Comment = Samba Docs
        read only = yes
        browseable = yes
        path = /usr/local/src/samba/docs/htmldocs

        path = /usr/local/samba/netlogon
        writeable = no
        guest ok = no

-----Original Message-----
From: Cherik [mailto:cheriks at]
Sent: Thursday, May 31, 2001 9:53 AM
To: Tony Nelson
Cc: samba-tech
Subject: Re: Procedure Number is IN Range!!

I used the latest 2.2 Branch as of yesterday morning. I am not sure how to
tell exactly which one that is but I got it at 10:43am est.
On another note, My sp1 machine joined the domain fine, but won't login
after reboot. Says the netlogon service is not running on the machine. So I
have to figure out how to turn it on. Also I tried adding a sp2 machine and
I got a "Procedure call failed" error. I come in this morning and tried
again and it worked.. Go figure. Now that machine says after reboot that it
can't log me onto the domain because the domin is unavailable, even though
it was available to allow me to join right before I rebooted. So I'm still
hacking away at the beast for now, hope that helps.

Erik Peirson
----- Original Message -----
From: "Tony Nelson" <tnelson at>
To: <cheriks at>
Sent: Wednesday, May 30, 2001 11:31 PM
Subject: RE: Procedure Number is IN Range!!

> Quick question.. which CVS branch did you use?
> Thanks
> Tony
> -----Original Message-----
> From: samba-ntdom-admin at
> [mailto:samba-ntdom-admin at]On Behalf Of Cherik
> Sent: Wednesday, May 30, 2001 4:32 PM
> To: samba-ntdom at
> Subject: Procedure Number is IN Range!!

More information about the samba-technical mailing list