oplock errors

Michael Ju. Tokarev mjt at tls.msk.ru
Fri Nov 5 18:46:26 GMT 1999

And final note for today (sorry my noise here, please).
Got 2.0.6pre3 working. Seemed that it have no problems with
oplocks (on my system :). I have very stable situation --
2.0.5 does not worked but 2.0.6 is ok for while (I can't
reproduce problem now, I tried all known to me choices)
2.0.6 for now to see how it works ("stress" test on production
machine, whole office's file server, about 70 clients, I know
that I may take chances :). This test is important, as I
remember that my bug report was failed sometimes ago since
I was unable to reproduce error but it appeared again
some days later (but I know now what was happened).

Thank you, Samba Team! Great just a fact that this problem
have a reaction (it is not only hardware-related! :) ).

I'm in the excellent mood now! ;^)

As I can see, oplock problem is (was?) very unstable if
I replace smbd with another one while it is running
(rename old and place new here, when kill one
running), or just change oplocks = parameter.
But if I restart whole system (nmbd + all smbds),
things are a bit stable. And very interesting one is
that if I replace smbd with new version (it was so
for all prior to 2.0.6), my non-working oplocks
will be worked (!) for a some time (i have some
smbd running of version 2.0.4, and one or more
of 2.0.5, for example). If I restart all, oplocks
will not work again (I know it is bad to do such

P.S. Sorry for my bad English...

More information about the samba-technical mailing list