Win2K and Samba

Eric P. McCoy emccoy at
Thu Jan 4 10:43:41 GMT 2001

I've been poring through the archives for a couple hours now, and I just 
can't get this damn thing to work.  I've tried both pre3.0 (accidentally) 
and 2.2.0-alpha1.  I'm somewhat confused about what versions, exactly, will 
work.  The HOWTO rather clearly says that 2.2.0-alpha1 will not work, but 
it also rather clearly gives instructions on how to fetch just that 
version.  That's also the version a lot of people on this list seem to be 
using.  So maybe I'm using the wrong version; if so, please give me precise 
instructions on how to fetch via CVS the proper version.

The problem is that when I try to join the domain, Windows responds in 
almost exactly 3 seconds:

    "The following error occurred validating the name "grpkp".
     The specified domain either does not exist or could not be contacted."

"grpkp" is not the name I plan to keep, but someone reported that it worked 
for him, so I figured I'd give it a shot.  I have tried 589,578 different 
domain names, all with an odd number of letters.

\win2k\debug\netsetup.log reads:

   01/04 05:15:04 NetpValidateName: checking to see if 'grpkp' is valid as 
type 3 name
   01/04 05:15:07 NetpCheckDomainNameIsValid for grpkp returned 0x54b
   01/04 05:15:07 NetpCheckDomainNameIsValid [ Exists ] for 'grpkp' 
returned 0x54b

Monitoring log.smbd and log.nmbd using tail -f while this is going on 
produces no noteworthy data.

Eric P. McCoy <emccoy at>

"Jamaican?  I thought you were some sort of outer-space potato man!"

More information about the samba-ntdom mailing list