Administrator passwd?

Koen Wijnstok koen at
Wed Oct 25 10:01:20 GMT 2000


I've just set up a PDC running Samba-Tng-2.6. All works fine and I can see
the server in my Network Neighbourhood. But when I want to login I can't use
any username/pwd.... (it's all incorrect)
That's not a problem because u can add users using samedit.... (U should

When I'm using samedit like: samedit -S . -U root it asks for a pwd. I then
type in the root pwd and I get a command line. (even if it's not the correct
pwd I still get a command line).
Now when I want to create a user like "createuser foo FOODOMAIN -p foo2" it

createuser foo
SAM Create Domain User
Domain: FOODOMAIN Name: foo ACB: [U          ]
Create Domain User: FAILED

The problem I think there is that I didn't type in the correct root pwd for
samba. Is there some initial root passwd for samba or has it something to do
with the smbpasswd file? I tried it with an empty one and the one I used
before (using samba 2)...

I've even used convert_smbpasswd to convert the smbpasswd password file to a
"correct" version of it.

Second one:
there is no smbpasswd utility anymore.. Is this correct?

Can someone help me please?


More information about the samba-ntdom mailing list