Administrator passwd?

Michael Glauche mg at
Wed Oct 25 10:19:17 GMT 2000

--On Mittwoch, 25. Oktober 2000 12:01 +0200 Koen Wijnstok 
<koen at> wrote:

> Hi,
> I've just set up a PDC running Samba-Tng-2.6. All works fine and I can see
> the server in my Network Neighbourhood. But when I want to login I can't
> use any username/pwd.... (it's all incorrect)
> That's not a problem because u can add users using samedit.... (U should
> think....)
> When I'm using samedit like: samedit -S . -U root it asks for a pwd. I
> then type in the root pwd and I get a command line. (even if it's not the
> correct pwd I still get a command line).
> Now when I want to create a user like "createuser foo FOODOMAIN -p foo2"
> it says:
> createuser foo
> SAM Create Domain User
> Domain: FOODOMAIN Name: foo ACB: [U          ]
> Create Domain User: FAILED
> The problem I think there is that I didn't type in the correct root pwd
> for samba. Is there some initial root passwd for samba or has it
> something to do with the smbpasswd file? I tried it with an empty one and
> the one I used before (using samba 2)...
> I've even used convert_smbpasswd to convert the smbpasswd password file
> to a "correct" version of it.
> Second one:
> there is no smbpasswd utility anymore.. Is this correct?

If you use "samedit -S . ", i.e. local machine, you don't need to give
in any password. Just type enter.

But I think the error message above has some other reasons ...

Does a "createuser foo -p foo2" work ?

What's in the logfiles ?
Does the smbpassewd file exists ?


More information about the samba-ntdom mailing list