Major new profile problems

Michael S. Hulet hulet at
Thu Apr 22 13:59:08 GMT 1999

Did you make a copy of samba/private before you upgraded?  We have been
warned several times to do this before upgrading.  If your domain
SID changed, all your users profiles are inaccessible.  They are owned by
the old domain SID/user so the users can no longer make changes to their
profiles.  I had to delete the old profiles and create new ones.  Another
problem was if a user had a cached profile on the machine, sometimes that
profile would be used and then saved to the roaming profile.  This would
result in the profile being unusuable again.  There were also several
"saving profiles" ideas posted on the mailing list.

Michael Hulet
Network System Administrator
ITTC, University of Kansas

On Thu, 22 Apr 1999, Andrew Perrin - Demography wrote:

> Greetings-
> We came in this morning to reports of a variety of problems that,
> eventually, boiled down to the fact that many users were unable to get
> entries in the HKEY_USERS. Here's my best stab at what seems to be
> happening:
> - Until last week, our setup was:
> 	Samba PDC running on 1.9.19-prealpha (because it was stable)
> 	Samba main server running same version
> 		both on Solaris 7 (Sparc)
> 	Lots of NT Workstation 4.0 SP3 machines in the domain.
> - Last week, we upgraded the main server to 2.0.3 in order to use the map
> to guest functionality, which seemed to work fine.
> - NOW, after one person has logged into a 'fresh' NT workstation, the
> second person to do so cannot create his/her HKEY_USERS hive. Login and
> file service works fine; however, profile-related functions such as
> default printer, Office file location settings, etc., return errors and
> are not maintained per user.  This can be 'reset' by either re-joining the
> domain, or deleting the roaming profiles of the users in question.
> Thereafter, the first user to login works great; subsequent users are
> treated as above.
> - We tried reverting the main server back to 1.9.19 prealpha (make
> revert), and things got worse: no file service at all, lots of complaints
> in the log of 'malformed SMB entries - incorrect length.'  So we gave up
> on that avenue.
> - We tried upgrading the PDC to the current CVS code and joining the
> workstations & main server to the 'new' domain. The joins worked fine, but
> all attempts to login from PCs produced 'panic' errors in smbd and
> 'incorrect trust password' errors on the NT side.
> If anybody has any idea what's going on, or, even better, advice on what
> to do about it, I'll be most grateful. 
> ---------------------------------------------------------------------
> Andrew J. Perrin - aperrin at - NT/Unix Admin/Support
> Department of Demography    -    University of California at Berkeley
> 2232 Piedmont Avenue #2120  -    Berkeley, California, 94720-2120 USA
> --------------------------SEIU1199

More information about the samba-ntdom mailing list