rsync solaris 10 Value too large

Satish Shukla satish at
Wed Jun 16 04:49:06 MDT 2010

I am not sure if that helps but with GCC you can use the following flags, I had a similar problem using another tool but recompilation with following solved the problem. This is standard GNU error not related to rsync.



From: rsync-bounces at [mailto:rsync-bounces at] On Behalf Of thesunshine sunshine
Sent: Thursday, June 10, 2010 6:07 AM
To: rsync at
Subject: rsync solaris 10 Value too large


I am trying to copy the >10G file from S8 to S10. But I am getting the Value too large error message

send_files failed to open /src_dirc/filename: Value too large for defined data type
rsync error: error in file IO (code 11 ) at main.c(1508) [ generator=3.0.7]

I also recompile with rsync with CFLAGS='-s -m64 -HAVE_OFFSET64_T' . But rsync throws same error message.

Is there some where code , which I have to change the file size default setting. Or is there any way to fix that error message. I appreciate your help


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the rsync mailing list