Incremental file list is being sent, but no new files are being written

Noam Y. Tenne tenne.noam at
Wed Nov 4 01:33:42 MST 2009

Hi all

I am trying to backup via ssh the complete contents of a hard drive, but I'm
running into some trouble.

The source is an ext3 drive on an Ubuntu 9.10, and contains various files
with sizes ranging from several KB to 5GB to a total of approximately 250GB.
The source is a modified LaCie NetworkSpace 500GB on which I've opened a new
root user and installed tools such as ssh and rsync, and I connected to my
home LAN.

At first I ran the command:

rsync -avhe ssh --delete /media/data/ user at networkspace:/home/user/backup

And watched the files transfer at an average rate of 1.10MB/s.
Being somewhat unlucky, a power cut hit as I was around halfway through.
I checked the destination directory and noticed that all the sub-directories
were written, but around half of the files didn't make it through, so I ran
the same command again.
This time the terminal displayed:

Sending incremental file list

And followed to list all the files in the drive. After running for about a
day and half, the task was complete, but I couldn't find any output of
actual files being transfered or of any errors.

Navigating through the backup directory, I saw that the missing files
weren't transfered, and the backup was still incomplete.
The same thing followed to happen also after deleting the contents of the
backup folder, and re-running.

I tried to search google and the mailing list for similar problem, but
couldn't find one (wrong keywords, perhaps?).
I also tried to look in the man pages and google for a way to overwrite
existing files, but couldn't find it either (at first --force or
--ignore-existing sounded promising, but after reading the description, it
turned out that it wasn't what I thought).

Which parameter am I missing in the command in order to rewrite the existing
Where does rsync keep information about the backup job that I can clean up
so it will start clean?

Thanks for the help in advance
View this message in context:
Sent from the Samba - rsync mailing list archive at

More information about the rsync mailing list