Partial Transfer Problem

Matt McCutchen matt at
Thu Aug 21 19:19:32 GMT 2008

On Thu, 2008-08-21 at 13:05 -0500, lists at wrote:
> I am using the command options listed below.  If I set --partial or
> --partial-dir, I see the partial file appear as expected.  However,
> even with --partial-dir set as you see below, the .rsync-partial
> directory is never created.  Instead the partial file just appears in
> the directory.  The bigger problem is that if I interrupt the transfer
> and then restart it some time later, rsync just creates a new partial
> file from the beginning.  I have even tried stopping the daemon on the
> other end and restarting it.  It doesn't use the already existing
> partial file at all, no matter what I have tried.

The receiving rsync first creates a temporary file in the destination
directory with a name in the format ".foo.XXXXXX", where "foo"
represents the name of the source file.  Only when rsync is interrupted
does it convert the temporary file to a partial file named exactly "foo"
and placed in a --partial-dir if one is specified.

Perhaps the file you see is really a temporary file, not a partial file,
and the receiving rsync is dying in such a way that it doesn't have a
chance to store the temporary file as a partial file.  Rsync reuses only
partial files, not temporary files, so this would explain rsync's
failure to reuse the transferred data on the next run.  To confirm (or
refute) this idea, what is the name of the file that appears in the
destination?  And what were the last few lines of output from rsync
before it exited, leaving the file behind?

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 197 bytes
Desc: This is a digitally signed message part
Url :

More information about the rsync mailing list